1. >
  2. >
  3. HTML/PHP・MySQLサーバー機能>
  4. PHPの利用

PHPの利用

※この機能は「PHP・MySQLサーバー」限定の機能です。

PHPについて

利用できるプログラムのバージョン

エックスドメインにてご利用可能なプログラムは下記の通りです。

PHP 7.1.x
PHP 7.0.x
現在公式にサポートされているバージョンです。
PHP 7.1.x、PHP 7.0.x は、PHP 5.6.x と比較してパフォーマンスが大幅に強化されています。
PHP 5.6.x 現在公式にサポートされているバージョンです。
パフォーマンスが大幅に強化されたPHP 7.1.x / PHP 7.0.x への移行を推奨します。
PHP 5.5.x 現在公式にサポートされているバージョンです。
よりサポート期間が長く、パフォーマンスが大幅に強化されたPHP 7.1.x / PHP 7.0.x への移行を推奨します。
PHP 5.3.3 旧バージョンです。
OSベンダーによるパッチでのセキュリティ修正は行いますが、パッチ提供頻度が減少しているため新規での利用は推奨しません。
PHP 7.1.x / PHP 7.0.x への移行を推奨します。
<ご注意>
プログラムのバージョンは非常に重要です。
バージョンの違いにより、お客様のプログラムが正常に動かないこともあります。
ご利用予定のプログラムの動作条件をよくご確認ください。
PHP関連の仕様一覧
PHPの動作CGI動作
PHPファイルの
パーミッション
600 / 604 / 644 / 700 / 705 / 755 のいずれか
PHPを設置する
フォルダのパーミッション
705 / 755 のいずれか
phpを設置する場所どこでも可能
利用可能なプログラムインストール済みです。
ただし、一部ライブラリは未導入です。
不足の際は、お客様ご自身でアップロードしてください。

ファイルのパーミッションは初期状態で604となっています。

利用を制限しているPHP関数について

以下のPHP関数は利用を制限しています。

  • ・dl
  • ・backtick_operator
  • ・shell_exec
  • ・system
  • ・exec
  • ・passthru
  • ・popen
  • ・phpinfo
  • ・proc_open
  • ・pcntl_exec
  • ・fscokopen
  • ・pfsockopen
  • ・stream_socket_client

マニュアルメニュー

お申込みについて
会員登録情報
ドメイン管理
HTML/PHP・MySQLサーバー機能
WordPress機能
FTPソフトの設定
広告について
メール機能
各管理パネルについて